If you installed a Plugin Alliance plugin, and now it’s asking for a license card, you probably downloaded a very old version of the plugin. We make those old iLok versions available for customers who bought their license years ago and then never upgraded. We stopped supporting the iLok in January 2012, so those old versions won’t work for current customers.

To download the current version, just go to the Manage Plugins page, select the plugin and find the download that you need.