Current versions of our plugins - MAC OS 10.9-10.14

You will need to have Mac OS 10.9-10.14 if you want to use the latest versions of our plugins. If you are having any issues with plugin validation or any other bug related symptoms since you updated to Mojave, please download and install the latest versions from your Manage Plugins page or by using the Installation Manager.


MAC OS 10.8

As of June 2018, Mac OS 10.8 Mountain Lion is no longer supported by the current versions of our plugins. You can obtain legacy versions of your plugins that should work on 10.8 here. Please note, if you don't see one of your plugins on there, it is most likely because this plugin has a different update schedule and the version that is available via the Installation Manager or on your Manage Registered Plugins should still work on Mac OS 10.8.


MAC OS 10.6 & 10.7

The current versions of our plugins no longer support Mac OS X 10.6 Snow Leopard and 10.7 Lion. If you are still using either of these operating systems and would like to be able to use all of our plugins, we recommend that you update to the current version of macOS.