All of our plugins that were released in 2018 and later no longer ship with any legacy versions and therefore, only the current system specs are supported by these plugins. Please consult this list to see which plugins have legacy installers that will be compatible with Mac OS 10.6 and 10.7:  Mac OS 10.6 and Windows Vista list